JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net
JPPF

The open source
grid computing
solution

 Home   About   Features   Download   Documentation   On Github   Forums 
October 03, 2022, 03:34:36 AM *
Welcome,
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: Nodes launched under windows 10 not visible in admin-ui - but are active  (Read 135 times)

caffeined

  • JPPF Padawan
  • *
  • Posts: 2

Firstly - thanks for this great framework - been spending my Christmas break playing with it and having great fun!

The issue I'm trying to resolve is that I am seeing that there are nodes that are being launched from windows that are not visible in the admin-ui - but are nonetheless being use when i launch a calculation.

I've got 3 raspberry pi cards and a Windows 10 laptop.  On the first of the raspberrypi-00 i run the driver and on raspberrypi-01 and -02 i am running one node each.  I'm using the n-body sample program - I'm launching the client from windows using ant run. 

I've modified the config file to have a lot of bodies (25000) and to use 125 bodies per task so that there are 200 tasks per job.   I reduced the number of time steps to 10 so that i get a nice round number of 2000 jobs total to run to make it easy to check that all tasks have run in the end.

When i run client like this i always see it finish with 2000 tasks completed and it takes around 2 minutes to complete.

However, i then launch some nodes from the windows machine.  They report connection success (see below).  But when i look at admin-ui it still shows only 2 nodes connected.  But when i run the client again (after resetting task counts and server statistics on admin-ui) it completes in less time and the number of tasks executed are less than 2000 - the "invisible" nodes are being used.....

   run:
        [java] node process id: 17564, uuid: F29EE8FA-D3E8-4C35-88CC-5C926AE71DFB
        [java] Attempting connection to the class server at raspberrypi-00:11111
        [java] RemoteClassLoaderConnection: Reconnected to the class server
        [java] JPPF Node management initialized on port 12001
        [java] Attempting connection to the node server at raspberrypi-00:11111
        [java] Reconnected to the node server
        [java] node successfully initialized



I initially had trouble getting the nodes to connect when using discovery, so it set it to false and then claimed to connect, but admin-ui is failing to see them although they are part of the network.  I've atteched the jppf-gui.properties and the jppf-node.properties.

Again, greatly enjoying using the tool but am just wondering if i'm misconfiguring something here or if i've maybe uncovered a bug.



Thanks!



Logged
Pages: [1]   Go Up
 
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at SourceForge.net. Fast, secure and Free Open Source software downloads