JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net
JPPF

The open source
grid computing
solution

 Home   About   Features   Download   Documentation   Forums 
December 13, 2018, 07:46:36 PM *
Welcome,
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: [Linux] Take long time to attempt connection to server on another machine  (Read 126 times)

kidmtt94

  • JPPF Knight
  • **
  • Posts: 15

Hi,

When I try to submit jobs to server (the server is start on other Linux machine), it take a long time to attempt connection.
Please help me to review this. And give me a solution to resolve this problem.
Notes: I submit jobs from Window machine  :)
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2241
    • JPPF Web site

Hello,

In order to investigate, could you please provide your JPPF client and server configurations, along with the JPPF version you're using?
Do you see any error or exception in the client or server log that may be relevant?
Additionally, could you let us know whether the Windows and Linux machines are on the same subnet or on different subnets?
Lastly, could you tell us what you mean by "it takes a long time"? How long is it exactly?

Thanks,
-Laurent
Logged

kidmtt94

  • JPPF Knight
  • **
  • Posts: 15

Hi,
I use the default configuration of node and server.
My two machines is same subnets
About the log of JPPF I will attached it.
Lastly, "take a long time" means it take 4 or 5 sec to "attempting connection" like the image attached.
Logged

kidmtt94

  • JPPF Knight
  • **
  • Posts: 15

Hellooooooooooo
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2241
    • JPPF Web site

Hello,

By default, the discovery of the JPPF driver is done via UDP multicast. I believe this is what is taking time when first connecting to the server. To remedy, you can try disabling UDP multicast discovery and manually confgure the connection to the driver in your client configuration, by setting the following properties:

Code: [Select]
# disable UDP multicast discovery
jppf.discovery.enabled = false

# declare the named driver(s) to connect to
jppf.drivers = driver1
# configure the driver1 connection
driver1.jppf.server.host = <jppf_driver_host>
driver1.jppf.server.port = 11111

Could you please try this and let us know if it resolves the issue?

Thanks,
-Laurent
Logged

kidmtt94

  • JPPF Knight
  • **
  • Posts: 15

I had try your solution but it did not resolve my problem.
This case just happens when the machine driver and the machine submitting job has different OS.
Does JPPF support for case different OS ?
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2241
    • JPPF Web site

Hi,

JPPF fully supports different OSes for clients, servers and nodes.
To try and determine what is taking a long time, we will need to increase the logging level, so we can have fine-grained timestamps associated with the log statements.

To do this, can you please follow these steps:

  • in your client application configuration, edit the Log4j configuration file (config/log4j.properties), and replace this line:
    log4j.rootLogger=INFO, JPPF
    with:
    log4j.rootLogger=DEBUG, JPPF
  • in your server configuration, edit the Log4j configuration file (config/log4j-driver.properties), and replace this line:
    log4j.rootLogger=INFO, JPPF
    with:
    log4j.rootLogger=DEBUG, JPPF
  • restart the server and client, wait until the client is connected, then post the resulting client and server log files so we can analyze them
Thanks,
-Laurent
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2241
    • JPPF Web site

Hello,

I just remembered a possible cause I encountered in the past. When connecting to a server, the client performs DNS name resolution, and this an take some time, depending on the network state nd DNS server performance. To disable DNS resolution in the client, just set "jppf.resolve.addresses = false" in its configuration file.

Sincerely,
-Laurent
Logged
Pages: [1]   Go Up
 
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at SourceForge.net. Fast, secure and Free Open Source software downloads