JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net

The open source
grid computing

 Home   About   Features   Download   Documentation   Forums 
September 21, 2018, 02:41:02 AM *
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: Can't start a local node  (Read 204 times)


  • JPPF Padawan
  • *
  • Posts: 3
Can't start a local node
« on: September 29, 2017, 12:03:34 PM »

Hello ,

I'm trying to install JPPF on my machine but when I'm trying to execute the script, I've got the following message over and over node process id: 145, uuid: 123BC1D1-D4B5-28AC-CCA9-2FAB7864485B
Attempting connection to the class server at localhost:11111
I've changed the conf file and specified that local nodes are enables
I've tried it on a Mac and on a Windows machine. Does someone have the same issue?


  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2240
    • JPPF Web site
Re: Can't start a local node
« Reply #1 on: September 29, 2017, 07:38:51 PM »


It seems here is a little bit of confusion. "Local node" can only apply to a server (also called driver). It means that the server will run a JPPF node inside its own JVM, instead of in a separate JVM.

My understanding of what you are doing is that you try to start a node configured with "jppf.local.node.enabled = true", is this correct? Since this configuration property only applies to a server, and no server is started, the messages you see repeating over and over simply indicate that the node is attempting to connect to a server on "localhost", and retrying until it succeeds.

If you could let us know what you are trying to achieve, I'm pretty sure we would find a way to do it.



  • JPPF Padawan
  • *
  • Posts: 3
Re: Can't start a local node
« Reply #2 on: October 02, 2017, 10:11:38 AM »

Thanks for your answer.

I was just trying to try the tutorial. I've tried first to follow the instructions without editing anything and  I had the same error message
Pages: [1]   Go Up
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at Fast, secure and Free Open Source software downloads