JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net
JPPF

The open source
grid computing
solution

 Home   About   Features   Download   Documentation   Forums 
October 18, 2019, 03:53:54 PM *
Welcome,
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: Support for WebLogic 12c  (Read 3528 times)

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Support for WebLogic 12c
« on: March 30, 2015, 04:04:31 PM »

Hello,
Currently I'm using an old version of JPPF (3.1.3) and for different reasons we cannot upgrade to a new version.

A couple of month ago a client ask us to migrate all our application from Jboss to WebLogic 12c included our JPPF client.
We have migrated all the applications and currently we are testing

We have lots of problems in JNDI names resolution. One of these is related to resource adapter descriptor (see attached image)

Is JPPF 3.1.3 compatible with WebLogic 12c ?
If not, is it possible to patch 3.1.3 or i must upgrade to a new version ? in the latter case which version do i have to use ?


thanks
Andrea Canalini
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #1 on: March 31, 2015, 06:52:09 AM »

Hi Andrea,

I just tested with the latest 3.1 release (v3.1.4) and a fresh install of Weblogic 12c (WebLogic Server 12.1.3.0.0)  and, as you can see in the attached screenshot, I had no issue with JNDI names. The demo worked perfectly and I could execute plenty of jobs.

What errors or exceptions are you getting, from both the Weblogic console and the server logs? Have you tried uninstalling then redeploying the resource adapter?

Thanks,
-Laurent
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #2 on: March 31, 2015, 03:55:50 PM »

Hi Laurent
I've tried the same test you have done
Deployed only the resource adapter. Even if we use the 3.1.3 version I've tried with  3.1.4.
With only the resource adapter i still see the JNDI tree with an error.

Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #3 on: March 31, 2015, 05:20:39 PM »

Maybe could be related to some OS issue
Currently my Weblogic server is installed on a Centos 6.5 system

I've start from a fresh weblogic installation, using the rar file from 3.1.4 distribution but still have my JNDI tree with errors

Bye
Andrea
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #4 on: April 01, 2015, 01:46:06 PM »

Hi Andrea,

I have also tested on a Centos 6.2 setup, and I still do not have any problem.
What would really help me to investigate this issue, is if you could find the actual error message(s) you are getting in the Weblogic console and post it in this thread. Also could you please post the server logs (e.g myserver.log) so we can try and find clues as to what is happening? Just knowing there is an error is not sufficient to investigate properly.

Thanks,
-Laurent
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #5 on: April 01, 2015, 04:26:57 PM »

Hi Laurent
With only the resource adapter we don't have any error except the JNDI red exclamation mark (see picture in the previous post)
When we try to deploy additional ear we get some strange error related to JDBC jndi name, like the jdbc lookup goes in erroe due to the fact that the JPPF JNDI tree is in error
If we remove the resource adapter, no error appears.


Bye
Andrea
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #6 on: April 01, 2015, 06:22:16 PM »

Hi Laurent
With only the resource adapter we don't have any error except the JNDI red exclamation mark (see picture in the previous post)
When we try to deploy additional ear we get some strange error related to JDBC jndi name, like the jdbc lookup goes in erroe due to the fact that the JPPF JNDI tree is in error
If we remove the resource adapter, no error appears.


Bye
Andrea
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #7 on: April 01, 2015, 08:03:41 PM »

Hi Laurent
Another info. A colleague test everything in a windows based system environment and despite the red exclamation mark on the JNDI tree we are able to deploy other ear without any errors

Bye
Andrea

Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #8 on: April 17, 2015, 10:35:24 AM »

Hi Laurent
We have found that if we try to set as target destination both the AdminServer and the ManagedServer the JNDI tree it's ok.

Have you done the same thing or you are able to work without such work-around ?

Thanks
Andrea
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #9 on: April 19, 2015, 11:35:52 AM »

Hi Andrea,

In my tests, I have only ever used a single Weblogic server, therefore the only target server I have is the admin server. That explains why I never had the JNDI tree issue.

-Laurent
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #10 on: April 20, 2015, 05:38:06 PM »

Hi Laurent
we opened a service request towards Oracle and they have reproduced the problem (they use an Admin server and a Managed server because it's a typical production environment)
They asked us if inside the resource adapter there some direct dependency to the admin server ?

Thanks
Andrea
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #11 on: April 22, 2015, 06:46:38 AM »

Hi Andrea,

The only thing that is actually specific to Weblogic in "jppf_ra_Weblogic.rar" is the deployment descriptor "META-INF/weblogic-ra.xml" and, after checking against the related Oracle documentation, I believe its content has no issue. Furthermore, and as far as I can tell, there is nothing specific to the admin server in there. All the other files in "jppf_ra_Weblogic.rar", including the code, are independent from the application server, meaning they're the same as used for Websphere, JBoss, Glassfish etc.

I have also conducted further tests and reproduced the JNDI tree issue when deploying only onto a managed server, but so far I don't see any indication of what's causing the problem. Both managed-server.log and managed-server.out do not seem to provide any clue pertaining to the problem.

-Laurent
Logged

acanalini

  • JPPF Master
  • ***
  • Posts: 30
Re: Support for WebLogic 12c
« Reply #12 on: April 22, 2015, 08:50:22 AM »

Hi Laurent
Thank you for your support
Last question (hopefully): did you also try to execute test after deploying the resource adapter in the managed server ? It Works ?

As reported in a previous mail we have this strange problem on JNDI resource when in the same managed server we deploy together with the resource adapter (by the way we include the rar inside the our ear) other application. And the problem is during the deploying phase: it means that the other applications cannot be started. Removing the rar everything is deployed correctly.
We thought that all was caused by the incorrect JNDI tree structure of the resource adapter. Also oracle confirmed such strange red exclamation mark even if they think it's only an visualization problem.
In any case we still have the problem open.

Bye
Andrea
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #13 on: April 22, 2015, 06:11:00 PM »

Hi Andrea,

I tried with the JPPF demo application. It doesn't work if the connector is only deployed to a managed server, because as expected the JNDI name eis/JPPFConnectionFactory could not be found. So definitely, the red marker in the JNDI tree is not just a visualization problem, but a real indicator that something is not working when binding the connection factory to JNDI or at some other stage of the deployment.

If the connector is also deployed to the admin server, then the demo application works on the managed server. Also for information, in my tests I'm always deploying the resource adapter as a standalone connector, not embedded within an ear file. Anyway, I don't think that's relevant since we're getting the issue in both cases.

Sincerely,
-Laurent
Logged

lolo

  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2256
    • JPPF Web site
Re: Support for WebLogic 12c
« Reply #14 on: April 22, 2015, 08:02:24 PM »

I finally found something. In a previous post I wrongly stated that there was no file related to the admin server, but in fact I missed that there is a "jndi.properties" file at the root of the .rar file, with this content:

Code: [Select]
#------------------------------------------------------------------
# Weblogic Configuration
#------------------------------------------------------------------

java.naming.factory.initial = weblogic.jndi.WLInitialContextFactory
java.naming.provider.url = t3://localhost:7001
So definitely, "t3://localhost:7001" refers to the admin server.

After removing "jndi.properties" from the .rar, and restarting the managed server, I was able to make the demo application work on the manged server. However, I can still see the red markers in the managed server's JNDI tree, so I'm not sure if it fully resolves the issue.

Could you try to do the same, either by removing the "jndi.properties" using a tool like 7-Zip, or by downloading a .rar I modified myself from here: http://www.jppf.org/private/3.1.4/jppf_ra_Weblogic.rar ?
Does it resolve all the issues, aside from the JNDI tree markers?

Thanks,
-Laurent
Logged
Pages: [1]   Go Up
 
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at SourceForge.net. Fast, secure and Free Open Source software downloads