JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net

The open source
grid computing

 Home   About   Features   Download   Documentation   On Github   Forums 
June 04, 2023, 07:51:25 PM *
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: [6.2, 6.3-alpha] JPPF admin-UI does not attempt to connect to a remote host  (Read 853 times)


  • JPPF Padawan
  • *
  • Posts: 2


I modified "" file in admin-UI as below.

Code: [Select] = myhost.remote


Code: [Select] =

The server is working well, too.

Code: [Select]
driver process id: 8094, uuid: 25390EE9-0E77-4BD9-93CC-13BDA82C69D2
ClientClassServer initialized
NodeClassServer initialized
ClientJobServer initialized
NodeJobServer initialized
management initialized and listening on port 11111
secure management initialized and listening on port 11443
Acceptor initialized
-  accepting plain connections on port 11111
- accepting secure connections on port 11443
JPPF Driver initialization complete

I turned off all port-based firewalls in all routes (Windows Desktop and my Linux server). I checked with Telnet and there is no problem with 11111, 11443 ports.

However, JPPF admin-UI searches only the localhost server and does not even attempt to access the remote address.

If the server is on localhost, it is scanned well.

I attached the log, so I'd like to know what the problem is.
« Last Edit: August 31, 2021, 09:31:57 PM by gnh1201 »


  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2272
    • JPPF Web site
Re: [6.2, 6.3-alpha] JPPF admin-UI does not attempt to connect to a remote host
« Reply #1 on: September 04, 2021, 07:39:38 AM »


Looking at the logs you provided, it looks like your admin console is configured to discover the driver through the built-in UDP multicast dsicovery mechanism.
I would suggest that you disable it (jppf.discovery.enabled = false) et configure the connection manually in the configuration file instead, as in this example:

Code: [Select]
jppf.discovery.enabled = false
jppf.drivers = driver1 = <ip_address_or_host_name>
driver1.jppf.server.port = 11111

Could you please try that and let us know if this works?



  • JPPF Padawan
  • *
  • Posts: 2
Re: [6.2, 6.3-alpha] JPPF admin-UI does not attempt to connect to a remote host
« Reply #2 on: September 04, 2021, 11:17:53 PM »

It works! Thanks :)

Code: [Select]
jppf.discovery.enabled = false


  • JPPF Padawan
  • *
  • Posts: 2

Hello Laurent, jnh1201,

@Laurent - thanks for that solution! Turning off the UDP discovery also did the trick for me.  Began working right away!

I wanted to also add some interesting details from my experience.

I have a small raspberry pi cluster cluster and was running the driver on one of them.  From my laptop i was attempting to use the admin gui and failing to connect.  Since the laptop i am using is a work machine it has firewall set up and i assumed it was a firewall issue.  As a test of this i attempted to have a node connect to the driver from my laptop.  To my surprise it worked fine.

I looked at the config for the node, expecting to find that its default is to *not* do UDP discovery-  but, no, it also uses that.

So I guess that maybe the node is 'smart' enough to go ahead with the explicit host/port if they're in the config file (, but the admin gui isn't?

I'd be curious if anyone can explain the difference in behavior - I'd just like to understand.  It's working now, so I'm going to go and play with my raspberry pi cluster, but if anyone has a comment i'd be interested....

(and thanks again to Laurent Cohen for all his work in developing JPPF!)

Pages: [1]   Go Up
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at Fast, secure and Free Open Source software downloads