JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net

The open source
grid computing

 Home   About   Features   Download   Documentation   On Github   Forums 
August 09, 2020, 09:58:05 AM *
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  
Pages: [1]   Go Down

Author Topic: run Node using wrapper  (Read 3101 times)


  • JPPF Padawan
  • *
  • Posts: 8
run Node using wrapper
« on: April 14, 2011, 08:02:41 PM »


May be i didn't look into the problem deep enough, but I am having issue getting the node running using the wrapper, I got the following error:

STATUS | wrapper  | 2011/04/13 14:12:24 | Launching a JVM...
INFO   | jvm 4    | 2011/04/13 14:12:24 | WrapperManager: Initializing...
INFO   | jvm 4    | 2011/04/13 14:12:24 | WrapperSimpleApp Error: Class org.jppf.node.NodeRunner found but could not be initialized: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory

I noticed that if i ran the Node through ant, i saw that NodeLauncher is being started:

hadoop   29546  0.0  0.2 284428 21444 pts/2    Sl+  Apr08   3:07 /usr/lib/jvm/java-6-sun- -Xmx16m -classpath /home/hadoop/jppf/JPPF-2.3-node/config:/home/hadoop/jppf/JPPF-2.3-node/lib/jppf-common-node-src.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/jppf-common-node.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/log4j-1.2.15.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/slf4j-api-1.6.1.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/slf4j-log4j12-1.6.1.jar org.jppf.node.NodeLauncher

When I use the Wrapper to run it,  JPPFNode start, NodeRunner is being started:
hadoop   29565  0.0  0.4 419624 39532 pts/2    Sl+  Apr08   3:19 /usr/lib/jvm/java-6-sun- -cp /home/hadoop/jppf/JPPF-2.3-node/config:/home/hadoop/jppf/JPPF-2.3-node/lib/jppf-common-node-src.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/jppf-common-node.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/log4j-1.2.15.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/slf4j-api-1.6.1.jar:/home/hadoop/jppf/JPPF-2.3-node/lib/slf4j-log4j12-1.6.1.jar -Xmx128m org.jppf.node.NodeRunner 39645

Is this correct? or do i need to change the wrapper config to change it to NodeLauncher?

thanks for your great help!!



  • Administrator
  • JPPF Council Member
  • *****
  • Posts: 2262
    • JPPF Web site
Re: run Node using wrapper
« Reply #1 on: April 15, 2011, 10:58:20 AM »

Hello Ken,

I believe the problem is due to a wrong classpath configuration in the node's wrapper-node.conf file. In v2.3, it uses v1.5.2 fir the slf4j libraries, whereas the actual jars are the v1.6.1 ones. Can you change the appropriate entries in the wrapper-node.conf and let us know if this resolves the problem?

The classpath entries should look like this:
Code: [Select]



  • JPPF Padawan
  • *
  • Posts: 8
Re: run Node using wrapper
« Reply #2 on: April 15, 2011, 11:51:48 PM »

yup, that solved it. my bad, i didnt check carefully on the version.
Pages: [1]   Go Up
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at Fast, secure and Free Open Source software downloads