JPPF, java, parallel computing, distributed computing, grid computing, parallel, distributed, cluster, grid, cloud, open source, android, .net
JPPF

The open source
grid computing
solution

 Home   About   Features   Download   Documentation   On Github   Forums 
February 05, 2023, 08:13:01 AM *
Welcome,
Please login or register.

Login with username, password and session length
Advanced search  
News: New users, please read this message. Thank you!
  Home Help Search Login Register  

Recent Posts

Pages: 1 [2] 3 4 ... 10
11
Hi lolo,
First of all, I want to thank you for your reply.
I checked What you suggested and I can confirm that the file jppf-common-6.2.jar is in the classpath.

I enclosed the screenshot of what I capture in the taskbar.

Can you please suggest to me other checks that I can make?

Thank you,
Paolo

12
Troubleshooting / Not all Nodes pick tasks submitted by driver, remain Idle
« Last post by preeti_jppf on August 04, 2021, 01:03:33 PM »
Hello,

We have 1 server with Apache tomcat installed acting as a JPPF client. On the same server we also have the JPPF Driver running too.
On another server we have 10 instances of JPPF nodes running. Each node is configured to run one task at a time. However when tomcat submits 10 or more tasks in parallel we are observing that only some random nodes pick these tasks while other nodes although available remain Idle.

Also the nodes picking the tasks are queuing up given they can only execute one task at a time. We see this behavior via the admin GUI and corresponding logs too.

Could someone help us understand this behavior and guide us with some pointers to resolve this issue.

CLIENT CONFIG:
 jppf.drivers = driver1
 jppf.discovery.enabled = false
 driver1.jppf.server.host = host1
 driver1.jppf.server.port = 18447
 driver1.jppf.ssl.enabled = false
 driver1.jppf.priority = 1
 driver1.jppf.pool.size = 1
 driver1.jppf.jmx.pool.size = 1

DRIVER CONFIG:
   
jppf.peer.discovery.enabled = false   
jppf.load.balancing.algorithm = manual
jppf.load.balancing.profile = manual_profile
jppf.load.balancing.profile.manual_profile.size = 1
jppf.local.node.enabled = false
jppf.server.port = 18447

NODE CONFIG:

jppf.node.management.port = 12001
jppf.discovery.enabled = false
jppf.drivers.discovery =host1:18447
jppf.processing.threads = 1



13
Forums / Re: Please post a message when you register
« Last post by preeti_jppf on August 04, 2021, 12:46:19 PM »
Hello!!
14
Forums / Re: Please post a message when you register
« Last post by rino1982 on August 04, 2021, 11:55:47 AM »
Hello
15
Installation and Configuration / Re: java -jar JPPF-6.1.4-Web-Installer.jar
« Last post by DenzelJPPF on July 12, 2021, 07:03:19 PM »
Hi Laurent,

thanks for the quick update
fyi I received the message using  Java 8 + 12 (w2k12/Windows 10).
Sincerely
Denzel
16
Installation and Configuration / Re: java -jar JPPF-6.1.4-Web-Installer.jar
« Last post by lolo on July 10, 2021, 09:36:34 AM »
Hello,

I was able to reproduce this behavior once, but only with Java 15. I had no issue with Java 8, 11 or 13. After killing the java process the first time, the error never happened again. However, I could capture the following error message:

Code: [Select]
C:\Temp>C:\java\jdk-15.0.2\bin\java -jar JPPF-6.2-Web-Installer.jar
java.lang.NullPointerException: Cannot invoke "java.io.InputStream.read(byte[])" because "<local5>" is null while trying to download https://www.jppf.org/download/6.2/JPPF-6.2-Web-Installer.pack-JPPF_Driver.jar

I will keep inivestigating and provide a status with my findings.

Sincerely,
-Laurent
17
Hello,

Just so this gets out ogf the way, could you check that jppf-common-6.2.jar is in the classpath of your JPPF driver? This is the jar file where the JPPFTaskBundle class is located.
Also, could you provide an instance of the logged error with the full exception stack trace, so we have a chance to understand what the driver is doing when the error occurs?

Thanks for your time,
-Laurent
18
Downloaded (https://jppf.org/downloads.php) and configured  ...\JPPF62\JPPF-6.2-driver and run the startDriver.bat W2K12.
Driver starts and all nodes are connecting.
Problem: the jppf-driver.log file grows very quickly within 1 minute > 1 GB
following pattern:
2021-07-09 20:01:03,059 [ERROR][org.jppf.server.nio.client.AsyncClientNioServer.handleSelectionException(109)]: error on AsyncClientContext[uuid=null, connectionUuid=null, peer=false, ssl=false, jobEntries=0, sendQueue size=0, interestOps=1] :
java.lang.ClassNotFoundException: org.jppf.server.protocol.JPPFTaskBundle
   at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
   at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
...
Did anybody face the same error messages and can provide a solution
Any kind of help is highly appreciated
thanks in advance
19
Installation and Configuration / java -jar JPPF-6.1.4-Web-Installer.jar
« Last post by DenzelJPPF on July 09, 2021, 10:04:53 PM »
Hi,

downloaded JPPF-6.2-Web-Installer.jar from https://jppf.org/downloads.php
run java -jar JPPF-6.2-Web-Installer.jar (on windows 10 workstation)
will open the JPPF Installation Wizard, hit next, accept license agreement, select installation path, hit ok , create the file in D:\temp\jppf62\izWrTe7103924964133648357.tmp
Pack installation progress --> finished
Overall Installation progress --> 6/6
see PDF attachment
and receive an Error window with the message Installation failed
exactly same behavior with JPPF-6.1.4-Web-Installer.jar

Anyone who made the same experience and found a solution?
Any support appreciated
thanks in advance
20
Troubleshooting / Re: [TOPOLOGY MANAGER DID NOT WROK]
« Last post by hoho23 on May 21, 2021, 05:31:22 PM »
Thank you, it works now,
 just a clarification, the code below did not put the execution runtime on sleep mode
Code: [Select]
Thread.sleep(5000L);Instead, I've used this code for the delay of 5 seconds
Code: [Select]
TimeUnit.SECONDS.sleep(5);
Pages: 1 [2] 3 4 ... 10
JPPF Powered by SMF 2.0 RC5 | SMF © 2006–2011, Simple Machines LLC Get JPPF at SourceForge.net. Fast, secure and Free Open Source software downloads