JPPF Forums

JPPF Help => Installation and Configuration => Topic started by: amirofy2002 on September 29, 2008, 07:14:49 PM

Title: Problem with Driver ( Server )
Post by: amirofy2002 on September 29, 2008, 07:14:49 PM
Hi

I'm a beginner with JPPF
at first i want run Driver on a Node
in this node I installed Ant,  PovRay, JDK 1.6
and set ANT_Home

my OS is Windows XP

at first i download server package from site and unzip it
C:\JPPF\JPPF-Driver

when in command prompt  i type ant run.driver
these message replied:

Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre1.6.
0\lib\tools.jar
Buildfile: build.xml

run.driver:
     [echo] starting the JPPF driver
     [java] Error: no `server' JVM at `C:\Program Files\Java\jre1.6.0\bin\server
\jvm.dll'.
     [java] Java Result: 4

BUILD SUCCESSFUL


can any one help me?
thanks
Title: Problem with Driver ( Server )
Post by: lolo on September 29, 2008, 07:58:53 PM
Hello Amir,

I believe the first warning "Unable to locate...." is harmless. It indicates that the version of Java installed on your machine is a JRE, rather than the expected JDK.

To resolve the second error, you will need to remove the following line in the build.xml:
Code: [Select]
<jvmarg value="-server"/>
(in the "run.driver" target)

Can you please try this and let us know if this works?

Thanks for your time,
-Laurent
Title: FIXED!
Post by: amirofy2002 on September 30, 2008, 10:08:36 AM
Hi Laurent

I just set my JDK Path in my system enviroment by:

set path=C:\program files\java\jdk1.6.0\bin;%path%

then every thing has been OK.


tnx for your reply