JPPF Issue Tracker
Please log in to bookmark issues
CLOSED  Bug report JPPF-139  -  JVM crash in IdleSystem sample on Ubuntu 12.04
Posted Apr 19, 2013 - updated Dec 27, 2014
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue details
  • Type of issue
    Bug report
  • Status
  • Assigned to
  • Progress
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
  • Posted by
  • Owned by
    Not owned by anyone
  • Category
  • Resolution
  • Priority
  • Reproducability
  • Severity
  • Targetted for
    icon_milestones.png JPPF 3.3.x
Issue description
When running a node in idle mode on Ubuntu 12.04, I get a JVM crash:

Node running in "Idle Host" mode
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f7a96bda2a0, pid=8701, tid=140164502202112
# JRE version: 7.0_21-b11
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.21-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  XDefaultRootWindow+0x0
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /home/lcohen/Workspaces/JPPF-b3.3/demo/hs_err_pid8701.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Additionally, I'm attaching the corresponding java core dump
Steps to reproduce this issue
Run a node in idle mode on Ubuntu 12.04 x64

Comment posted by
Apr 19, 22:59
A file was uploaded. java core dumpicon_open_new.png
Comment posted by
Apr 21, 08:16
I identified two issues preventing the sample from working:
  1. the JVM crash was caused by XOpendDIsplay(null) returning null. Depending on how the node is launched, the DISPLAY environment variable may not be set. This was happening when I launched the node from Eclipse. I had to explicitely define DISPLAY=:0.0 in the launch configuration.
  2. Once that was solved I then got an UnstatisfiedLinkError due to the JVM being unable to load the library. Tt seems that by default, the Xss library (X screen saver extensions) is not installed in recent versions of Ubuntu. So I had to install it with "sudo apt-get install libxss1".
After all this, it is now working.
Comment posted by
Apr 21, 09:03
Fixed in branch b3.3 revision 2698.
Comment posted by
Apr 21, 20:25
Fixed in trunk revision 2699

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Confirmed to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from lolo4j to Not being worked on.