You are raising a good point with the jppf-node.jar
It actually contains classes common to all JPPF components: client, server, nodes, admin tool. I get that the name is misleading and we'll change it.
How about jppf-common-node.jar?
Another thing I can add to our todo list is a switch in our build scripts to generate either a single jar file for each component, or multiple ones as it is now, or both. Is that acceptable?
Thank you very much for your feeback.